summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYouness Alaoui <youness.alaoui@collabora.co.uk>2009-07-24 15:55:14 -0400
committerYouness Alaoui <youness.alaoui@collabora.co.uk>2009-07-24 15:55:14 -0400
commitdbc4c346f305a86eb1bb7068bc311238d6604739 (patch)
tree36f6e70b424a108b57a01130d519923b2b065e17 /configure.ac
parent20c1dbe75d74d3db637011d63b74d134dee666aa (diff)
downloadlibnice-dbc4c346f305a86eb1bb7068bc311238d6604739.tar.gz
Add the AC_DEFINE for HAVE_GETIFADDRS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index adf505b..b02adba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,7 +56,9 @@ AC_HEADER_ASSERT
AC_HEADER_STDBOOL
AC_DEFINE([_FORTIFY_SOURCE], [2], [Define to `2' to get GNU/libc warnings.])
AC_DEFINE([NICEAPI_EXPORT], [ ], [Public library function implementation])
-AC_CHECK_HEADERS([arpa/inet.h net/in.h ifaddrs.h])
+AC_CHECK_HEADERS([arpa/inet.h net/in.h ifaddrs.h], \
+ [AC_DEFINE(HAVE_GETIFADDRS, [1], \
+ [Whether getifaddrs() is available on the system])])
LIBNICE_CFLAGS="-Wall"
dnl if asked for, add -Werror if supported