summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Adam <jakub.adam@collabora.com>2018-12-18 10:36:53 +0100
committerJakub Adam <jakub.adam@collabora.com>2018-12-18 18:34:19 +0100
commit83c5d0fce35edb481125e4ee51d12700cd8eb663 (patch)
treea55bf56b82a0e4a09215e67884ec66f1590f07b3 /configure.ac
parentc5ef4700add00af16a5add34fb0768c5519f214e (diff)
downloadlibnice-83c5d0fce35edb481125e4ee51d12700cd8eb663.tar.gz
udp-bsd: Fix recv with small buffer on Windows
The underlying GSocket implementation on Windows returns an error when the user-provided buffer isn't large enough to fit the whole datagram received on a message-oriented socket. When this occurs, in order to preserve identical behavior of udp-bsd NiceSocket across platforms, we have to mute the error and set the received message length to the size of the provided NiceInputMessage. Any excess portion of the message gets discarded. Fixed udp-bsd test on Windows. GLib 2.48 is required in order to use G_IO_ERROR_MESSAGE_TOO_LARGE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ddcc4e4..91aa946 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,7 +95,7 @@ AC_CHECK_HEADERS([ifaddrs.h],
AC_CHECK_TYPES([size_t, ssize_t])
# Also put matching version in LIBNICE_CFLAGS
-GLIB_REQ=2.44
+GLIB_REQ=2.48
LIBNICE_CFLAGS="-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_44 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_44"