summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2014-06-30 17:28:09 +0100
committerOlivier Crête <olivier.crete@collabora.com>2014-07-07 15:47:02 -0400
commit9981969d7dc14d6eb67389b56c37194938841c61 (patch)
treeab72eb3febcdbee43d682c76dfa058d61b50cc2f /configure.ac
parent46fd481b5a1cb7746e9d5c5d16695a6fb7f1de76 (diff)
downloadlibnice-9981969d7dc14d6eb67389b56c37194938841c61.tar.gz
nice: Expose UPnP support in nice.pc.in
It might be useful for dependent packages to check whether libnice was compiled with UPnP support, so expose that as a variable in the pkg-config file, set to ‘true’ if supported, and the empty string otherwise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b915249..124c9ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,6 +274,7 @@ fi
if test "x$HAVE_GUPNP" = "xyes"; then
AC_DEFINE(HAVE_GUPNP,,[Have the GUPnP IGD library])
+ UPNP_ENABLED="true"
else
GUPNP_PACKAGES_PUBLIC=""
GUPNP_PACKAGES_PRIVATE=""
@@ -285,6 +286,7 @@ AC_SUBST([GUPNP_PACKAGES_PRIVATE])
AC_SUBST([GUPNP_PACKAGES])
AC_SUBST(HAVE_GUPNP)
+AC_SUBST([UPNP_ENABLED])
dnl Test coverage
AC_ARG_ENABLE([coverage],