summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKai Vehmanen <first.surname@nokia.com>2007-05-02 14:23:00 +0000
committerKai Vehmanen <first.surname@nokia.com>2007-05-02 14:23:00 +0000
commit35811637f66080e813b7d3a7087764887c8fbffc (patch)
tree8c271eb4deff7ed8c0ca83af5111e355d541f152 /configure.ac
parentb02604c560d5fd25cd181d5bb3c3631abb249e44 (diff)
downloadlibnice-35811637f66080e813b7d3a7087764887c8fbffc.tar.gz
Added checks for OpenSSL and librt.
darcs-hash:20070502142305-77cd4-1455a87f80884d1a56d4bbbd739b9e312c1d8ddb.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ff5c9ed..dfa2b37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,15 +1,16 @@
AC_PREREQ(2.60)
AC_INIT(nice, 0.0.1)
-AC_CONFIG_SRCDIR([.])
+AC_CONFIG_SRCDIR([agent/agent.c])
AC_CONFIG_HEADER([config.h])
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE([-Wall -Wno-portability])
AC_CONFIG_FILES([
Makefile
address/Makefile
agent/Makefile
tests/Makefile
stun/Makefile
+ stun/tests/Makefile
local/Makefile
udp/Makefile
nice/Makefile
@@ -21,9 +22,22 @@ AC_CONFIG_FILES([
# Checks for programs.
AC_PROG_CC
+AC_PROG_CC_C99
+AC_USE_SYSTEM_EXTENSIONS
AC_PROG_LIBTOOL
+# Checks for compiler features
+
+AC_C_RESTRICT
+AC_HEADER_ASSERT
+AC_HEADER_STDBOOL
+AC_DEFINE([_FORTIFY_SOURCE], [2], [Define to `2' to get GNU/libc warnings.])
+
# Checks for libraries.
+AC_CHECK_LIB(rt, clock_gettime, [LIBRT="-lrt"], [LIBRT=""])
+AC_SUBST(LIBRT)
+
+PKG_CHECK_MODULES(OPENSSL, [openssl])
PKG_CHECK_MODULES(GLIB, [dnl
glib-2.0 >= 2.10 dnl