summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Mooney <Tim.Mooney@ndsu.edu>2013-10-29 16:52:12 +0000
committerOlivier CrĂȘte <olivier.crete@collabora.com>2013-10-29 16:52:12 +0000
commitf3a68a35f6ac423376cc9e26d66fac9dd882bc97 (patch)
tree024c46334f15bb14ebefa38a06aba6d7baaae866 /configure.ac
parent3a1334c103d745f683e4d9c3467ae3715ebc2628 (diff)
downloadlibnice-f3a68a35f6ac423376cc9e26d66fac9dd882bc97.tar.gz
Add special case to make it compile on Solaris
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d997f1e..35e4bc0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,17 @@ dnl if asked for, add -Werror if supported
if test "x$LIBNICE_RELEASE" != "xyes"; then
LIBNICE_CFLAGS="$LIBNICE_CFLAGS -Werror"
fi
+#
+# Fixes for Solaris
+#
+AC_SEARCH_LIBS([inet_pton],[nsl])
+AC_SEARCH_LIBS([socket],[socket inet])
+case $host in
+ *-*-solaris* )
+ AC_DEFINE(_XOPEN_SOURCE, 600, Needed to get declarations for msg_control and msg_controllen on Solaris)
+ AC_DEFINE(__EXTENSIONS__, 1, Needed to get declarations for msg_control and msg_controllen on Solaris)
+ ;;
+esac
AC_SUBST(LIBNICE_CFLAGS)
AC_MSG_NOTICE([set LIBNICE_CFLAGS to $LIBNICE_CFLAGS])