summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Becker <chemobejk@gmail.com>2019-06-27 13:33:25 +0300
committerStefan Becker <chemobejk@gmail.com>2019-06-27 19:52:31 +0300
commit099ff65c0371483ded4a3a7e905adfeea0faf6f6 (patch)
treec479913e8fd5e3de591bff5ba63daaaace270cca /configure.ac
parent056de4aeed8def0e2942c8ebb74bb3bd96b44a93 (diff)
downloadlibnice-099ff65c0371483ded4a3a7e905adfeea0faf6f6.tar.gz
build: add default ignore network interface prefix
By default libnice now ignores network interfaces from virtual machines and containers, i.e. names that start with "docker", "veth", "virbr" and "vnet". If you want to disable this feature override the default with ./configure --without-ignored-network-interface-prefix ... ./configure --with-ignored-network-interface-prefix= ... meson setup -D ignored-network-interface-prefix= ... meson setup -D ignored-network-interface-prefix=[] ...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 42d1fe9..c1367c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -402,7 +402,8 @@ AC_ARG_WITH([ignored-network-interface-prefix],
[Ignore network interfaces whose name starts with a string from this list in the ICE connection
check algorithm. For example, interfaces "virbr" in the case of the virtual bridge
handled by libvirtd, do not help in finding connectivity.])],
- [interface_prefix="$withval"])
+ [interface_prefix="$withval"],
+ [interface_prefix="docker,veth,virbr,vnet"])
AS_IF([test -n "$interface_prefix" && test "x$interface_prefix" != "xno"],
[[interface_prefix_list=`echo $interface_prefix | sed 's/,/","/g'`]
AC_DEFINE_UNQUOTED([IGNORED_IFACE_PREFIX],["$interface_prefix_list"],