summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Becker <chemobejk@gmail.com>2019-06-27 12:22:53 +0300
committerStefan Becker <chemobejk@gmail.com>2019-06-27 19:52:31 +0300
commitd4bc4fa35b5ea745195d116e1329fac6ad28dd5b (patch)
tree086e2df18d190361d08da70ac3fd53dae07abc91 /configure.ac
parent7b4b46f97c2d37da38eba4637dcf040105269772 (diff)
downloadlibnice-d4bc4fa35b5ea745195d116e1329fac6ad28dd5b.tar.gz
build: make prefix option accept a list of strings
The parameter for the ignored network interface prefix build option accepts a comma-separated string now. This list will be converted to a comma-separated list of string literals for the C code. Disable the feature: ./configure ... ./configure --with-ignored-network-interface-prefix= ... meson setup -D ignored-network-interface-prefix= ... meson setup -D ignored-network-interface-prefix=[] ... Ignore interfaces whose names start with "virbr": ./configure --with-ignored-network-interface-prefix=virbr ... meson setup -D ignored-network-interface-prefix=virbr ... Ignore interfaces whose names start with "virbr" or "veth": ./configure --with-ignored-network-interface-prefix=virbr,veth ... meson setup -D ignored-network-interface-prefix=virbr,veth ...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 147b033..5254154 100644
--- a/configure.ac
+++ b/configure.ac
@@ -395,16 +395,17 @@ AM_CONDITIONAL([ENABLE_GTK_DOC], false)
# GObject introspection
GOBJECT_INTROSPECTION_CHECK([1.30.0])
-dnl Ignore a specific network interface name prefix from the connection check
-AC_MSG_CHECKING([whether to ignore a specific network interface name prefix])
+dnl Ignore specific network interface name prefixes from the connection check
+AC_MSG_CHECKING([whether to ignore specific network interface name prefixes])
AC_ARG_WITH([ignored-network-interface-prefix],
- [AS_HELP_STRING([--with-ignored-network-interface-prefix=string],
- [Ignore network interfaces whose name starts with "string" from the ICE connection
+ [AS_HELP_STRING([--with-ignored-network-interface-prefix=string@<:@,string...@:>@],
+ [Ignore network interfaces whose name starts with a string from this list in the ICE connection
check algorithm. For example, interfaces "virbr" in the case of the virtual bridge
handled by libvirtd, do not help in finding connectivity.])],
[interface_prefix="$withval"])
AS_IF([test -n "$interface_prefix"],
- [AC_DEFINE_UNQUOTED([IGNORED_IFACE_PREFIX],["$interface_prefix"],
+ [[interface_prefix_list=`echo $interface_prefix | sed 's/,/","/g'`]
+ AC_DEFINE_UNQUOTED([IGNORED_IFACE_PREFIX],["$interface_prefix_list"],
[Ignore this network interface prefix from the connection check])
AC_MSG_RESULT([yes, $interface_prefix])],
[AC_MSG_RESULT([no])])