summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2016-03-07 09:27:00 +0000
committerOlivier CrĂȘte <olivier.crete@collabora.com>2017-03-31 18:25:07 -0400
commitd81c0d5f535e7c335f7c7f57359a1863fbdd867e (patch)
tree4fc1d68940f4f69618f92f89447d7dd355bf10bf /configure.ac
parent6c63f74af83c0697318cc690df9ba2bd9ad677ab (diff)
downloadlibnice-d81c0d5f535e7c335f7c7f57359a1863fbdd867e.tar.gz
stun: Add libgcrypt dependency
This will shortly be used to implement secure random number generation. Differential Revision: https://phabricator.freedesktop.org/D1609
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6be4010..1075610 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,6 +301,22 @@ AC_SUBST([GUPNP_PACKAGES])
AC_SUBST(HAVE_GUPNP)
AC_SUBST([UPNP_ENABLED])
+dnl libgcrypt
+GCRYPT_VERSION=1.4.5
+GCRYPT_LIBVER=1
+
+AM_PATH_LIBGCRYPT($GCRYPT_LIBVER:$GCRYPT_VERSION,,AC_MSG_ERROR([[
+***
+*** libgcrypt was not found. You may want to get it from
+*** ftp://ftp.gnupg.org/gcrypt/libgcrypt/
+***
+]]))
+libgcrypt=yes
+AC_DEFINE_UNQUOTED(LIBGCRYPT_VERSION, "$GCRYPT_VERSION", [Version of GCRYPT we expect])
+
+AC_SUBST([LIBGCRYPT_CFLAGS])
+AC_SUBST([LIBGCRYPT_LIBS])
+
dnl Test coverage
AC_ARG_ENABLE([coverage],
[AS_HELP_STRING([--enable-coverage],