summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2014-04-03 12:29:04 +0100
committerPhilip Withnall <philip.withnall@collabora.co.uk>2014-04-03 15:02:01 +0100
commitfac5f3648041fd5225d5e1623625d7f6a9df615b (patch)
tree365805f53c64d446fd501446b9dbad41f7636c2c /configure.ac
parentcee3641b3255b2fd564ed446d789554aefda7394 (diff)
downloadlibnice-fac5f3648041fd5225d5e1623625d7f6a9df615b.tar.gz
build: Check for [s]size_t before redefining them on MinGW
MinGW defines size_t and ssize_t for us, so we should not unconditionally redefine them in stun/win32_common.h. Add an AC_CHECK_TYPES configure check to avoid this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 745b40c..9b83742 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,7 @@ AC_CHECK_HEADERS([arpa/inet.h net/in.h])
AC_CHECK_HEADERS([ifaddrs.h], \
[AC_DEFINE(HAVE_GETIFADDRS, [1], \
[Whether getifaddrs() is available on the system])])
+AC_CHECK_TYPES([size_t, ssize_t])
# Also put matching version in LIBNICE_CFLAGS
GLIB_REQ=2.30