summaryrefslogtreecommitdiff
path: root/gst/Makefile.am
diff options
context:
space:
mode:
authorDafydd Harries <dafydd.harries@collabora.co.uk>2007-02-13 19:30:00 +0000
committerDafydd Harries <dafydd.harries@collabora.co.uk>2007-02-13 19:30:00 +0000
commitda51ef41807cdf9a0d48b2796a6ae1167e05bb91 (patch)
tree87bd6ba7b9c7a7430da4ce4460c863c270b30486 /gst/Makefile.am
parentc3d5265f428fe26497c216c6ceb755f3b8b100ad (diff)
downloadlibnice-da51ef41807cdf9a0d48b2796a6ae1167e05bb91.tar.gz
add test for GStreamer code
darcs-hash:20070213193023-c9803-249e9c2c5c8b0c677a22f5db633d04606c6c6f93.gz
Diffstat (limited to 'gst/Makefile.am')
-rw-r--r--gst/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/gst/Makefile.am b/gst/Makefile.am
index 2841c6a..fd29c17 100644
--- a/gst/Makefile.am
+++ b/gst/Makefile.am
@@ -5,7 +5,8 @@ AM_CFLAGS = -Wall -Werror \
-I $(top_srcdir)/udp \
-I $(top_srcdir)/agent \
-I $(top_srcdir)/random \
- -I $(top_srcdir)/address
+ -I $(top_srcdir)/address \
+ -I $(top_srcdir)/stun
COMMON_LDADD = \
$(GST_LIBS) \
@@ -29,6 +30,16 @@ libgstnice_la_LDFLAGS = -module -avoid-version
# programs
+check_PROGRAMS = \
+ test
+
+test_LDADD = \
+ $(COMMON_LDADD) \
+ ../stun/libstun.la \
+ libgstnice.la
+
+TESTS = $(check_PROGRAMS)
+
noinst_PROGRAMS = \
jingle-gst-test-server