summaryrefslogtreecommitdiff
path: root/gst/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-07-30 16:42:52 +0100
committerOlivier Crête <olivier.crete@collabora.com>2018-12-14 14:47:01 -0500
commit0e0f89d2b916dc0475787e0970bb692882ee3de2 (patch)
treee63653836a4e07fd0d54c5b2b5b52d7535d37c91 /gst/meson.build
parented70ea09b6b283b25d3047443c00a14c8cb29e1a (diff)
downloadlibnice-0e0f89d2b916dc0475787e0970bb692882ee3de2.tar.gz
Add support for Meson build system
Diffstat (limited to 'gst/meson.build')
-rw-r--r--gst/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/gst/meson.build b/gst/meson.build
new file mode 100644
index 0000000..15a5079
--- /dev/null
+++ b/gst/meson.build
@@ -0,0 +1,16 @@
+gst_nice_sources = [
+ 'gstnicesrc.c',
+ 'gstnicesink.c',
+ 'gstnice.c',
+]
+
+gst_nice_args = ['-DGST_USE_UNSTABLE_API']
+
+libgstnice = library('gstnice',
+ gst_nice_sources,
+ c_args : gst_nice_args,
+ include_directories: nice_incs,
+ dependencies: [nice_deps, gst_dep],
+ link_with: libnice,
+ install_dir: join_paths(get_option('libdir'), 'gstreamer-1.0'),
+ install: true)