summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-11-03 00:30:01 +0000
committerOlivier Crête <olivier.crete@collabora.com>2018-12-14 14:47:01 -0500
commit8ce2b76b3228ee4812b943d1436e5a31c8d4ab6f (patch)
tree91c9ddc7cbc5ec8046c7205277f421425373660e /meson.build
parent15c2d359fba8f4b3fd5539a879c853fe74f92b21 (diff)
downloadlibnice-8ce2b76b3228ee4812b943d1436e5a31c8d4ab6f.tar.gz
meson: add fallbacks for glib and gio
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c8c1be6..022fe05 100644
--- a/meson.build
+++ b/meson.build
@@ -163,8 +163,10 @@ foreach w : warnings
endforeach
# Dependencies
-glib_dep = dependency('gio-2.0', version: glib_req)
-gthread_dep = dependency('gthread-2.0')
+glib_dep = dependency('gio-2.0', version: glib_req,
+ fallback: ['glib', 'libgio_dep'])
+gthread_dep = dependency('gthread-2.0',
+ fallback: ['glib', 'libgthread_dep'])
# Cryto library
opt_cryptolib = get_option('crypto-library')