summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJakub Adam <jakub.adam@collabora.com>2019-01-02 12:53:56 +0100
committerJakub Adam <jakub.adam@collabora.com>2019-01-02 13:06:10 +0100
commit91f99b2240768e2a63ea3c8d8335f0b9b267c012 (patch)
treee85d919e2d06020644647d93c0a82114b75815cd /meson.build
parent8a6b7420c42ff11f697ba0fdb86ae0c60473cc8e (diff)
downloadlibnice-91f99b2240768e2a63ea3c8d8335f0b9b267c012.tar.gz
meson: Add fallback for openssl
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c905399..f6d7d93 100644
--- a/meson.build
+++ b/meson.build
@@ -188,7 +188,8 @@ if opt_cryptolib != 'openssl'
if opt_cryptolib != 'auto'
error('GnuTLS requested as crypto library, but not found')
endif
- crypto_dep = dependency('openssl', required: false)
+ crypto_dep = dependency('openssl', required: false,
+ fallback: ['openssl', 'openssl_dep'])
cdata.set('HAVE_OPENSSL', crypto_dep.found())
endif
else