summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRohan Garg <rohangarg@kubuntu.org>2012-03-17 00:52:00 +0530
committerRohan Garg <rohangarg@kubuntu.org>2012-05-01 21:38:33 +0530
commit13ed6c468c13156dcba8f385f2f7e629e9e2da89 (patch)
tree84902416155a3012e5e18d3969936430c81593e6 /tests/Makefile.am
parentce745d251ef07333b2929af36570b2d98eac8a9c (diff)
downloadlibnice-13ed6c468c13156dcba8f385f2f7e629e9e2da89.tar.gz
Added new tests for dribble mode in libnice
4 tests in total : * Common to all : - Gather lagent and ragent candidates - Delay STUN response for lagent - Make sure connchecks succeed and data is sent across to lagent * standard_test : - Set remote candidates for lagent while lagent is still gathering it's own candidates * bad_credentials_test : - Set incorrect credentials for both lagent and ragent - Make sure connchecks fail - Signal STUN response and set correct credentials * bad_candidate_test : - Set a bad remote candidate for lagent - Make sure connchecks fail - Signal STUN response and set correct remote candidates * new_candidate_test : - As soon as a new local candidate is found set it as the remote candidate for the other agent
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2cfc813..88cb73f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -32,7 +32,8 @@ check_PROGRAMS = \
test-restart \
test-fallback \
test-thread \
- test-dribble
+ test-dribble \
+ test-new-dribble
dist_check_SCRIPTS = \
check-test-fullmode-with-stun.sh \
@@ -64,6 +65,8 @@ test_fallback_LDADD = $(COMMON_LDADD)
test_dribble_LDADD = $(COMMON_LDADD)
+test_new_dribble_LDADD = $(COMMON_LDADD)
+
all-local:
chmod a+x $(srcdir)/check-test-fullmode-with-stun.sh
chmod a+x $(srcdir)/test-pseudotcp-random.sh