summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJose Antonio Santos Cadenas <santoscadenas@gmail.com>2015-03-24 12:07:34 +0100
committerOlivier CrĂȘte <olivier.crete@collabora.com>2015-03-27 19:42:00 -0400
commit20ea22e0a11a9bdfe4d8125b68083249b694338a (patch)
tree205aa55611a644047a1fbd3b0fb4adc27bb7c2d1 /tests/Makefile.am
parent781f3ab12c48c79da13dee4073f56a3936a5dced (diff)
downloadlibnice-20ea22e0a11a9bdfe4d8125b68083249b694338a.tar.gz
nicesink: Add test for buffer list support
https://bugs.freedesktop.org/show_bug.cgi?id=89609
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 84c37be..c7b1fd9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,6 +8,9 @@
include $(top_srcdir)/common.mk
+TESTS_ENVIRONMENT=\
+ GST_PLUGIN_PATH=${GST_PLUGIN_PATH}:$(top_builddir)/gst
+
AM_CFLAGS = \
$(LIBNICE_CFLAGS) \
$(GLIB_CFLAGS) \
@@ -51,6 +54,10 @@ dist_check_SCRIPTS = \
check-test-fullmode-with-stun.sh \
test-pseudotcp-random.sh
+if HAVE_GST_CHECK
+check_PROGRAMS += test-gstreamer
+endif
+
TESTS = $(check_PROGRAMS) $(dist_check_SCRIPTS)
noinst_HEADERS = test-io-stream-common.h
@@ -109,6 +116,9 @@ test_tcp_LDADD = $(COMMON_LDADD)
test_icetcp_LDADD = $(COMMON_LDADD)
+test_gstreamer_CFLAGS = $(AM_CFLAGS) $(GST_CHECK_CFLAGS)
+test_gstreamer_LDADD = -lnice -L$(top_builddir)/nice/.libs $(GLIB_LIBS) $(GUPNP_LIBS) $(GST_CHECK_LIBS) $(GST_LIBS)
+
all-local:
chmod a+x $(srcdir)/check-test-fullmode-with-stun.sh
chmod a+x $(srcdir)/test-pseudotcp-random.sh