summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2015-06-22 11:30:31 +0100
committerPhilip Withnall <philip.withnall@collabora.co.uk>2015-10-18 17:00:13 +0100
commit53283c218a5eb7a29e7019ac320e74f9dbe4b3fc (patch)
tree3fa3d5a13a1ec966393dc75f503818959a02a2bb /tests/Makefile.am
parentaef748ec7d0b06067312e5cc761a6375cd0f699c (diff)
downloadlibnice-53283c218a5eb7a29e7019ac320e74f9dbe4b3fc.tar.gz
tests: Enable G_MESSAGES_DEBUG for all unit tests
Now that we’re using automake’s parallel test harness, it automatically redirects all the debug log spew away from the console, so we should always have it enabled. Reviewed-by: Olivier Crête <olivier.crete@collabora.com> Differential Revision: https://phabricator.freedesktop.org/D292
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3644091..ffa0cb8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,6 +22,10 @@ AM_CFLAGS = \
-I $(top_srcdir)/stun
AM_CPPFLAGS = -DG_LOG_DOMAIN=\"libnice-tests\"
+AM_TESTS_ENVIRONMENT = \
+ G_MESSAGES_DEBUG=all \
+ NICE_DEBUG=all;
+
COMMON_LDADD = $(top_builddir)/agent/libagent.la $(top_builddir)/socket/libsocket.la $(GLIB_LIBS) $(GUPNP_LIBS)
check_PROGRAMS = \