summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOlivier CrĂȘte <olivier.crete@collabora.com>2014-02-24 23:05:44 -0500
committerOlivier CrĂȘte <olivier.crete@collabora.com>2014-02-25 00:51:31 -0500
commit91b93b44a63e7a1b49111926e4515f39617acfe1 (patch)
tree7e52de06bbaf5548e383b238010b626deb59ec31 /tests/Makefile.am
parent00e91acecc338d4ff3822384650912cfd7b68f7e (diff)
downloadlibnice-91b93b44a63e7a1b49111926e4515f39617acfe1.tar.gz
tests: Split racy "closing" into a test for stopping while reading or writing
We wan't to make sure not to have a race where a thread blocks in a blocking receive or send while nice_agent_remove_stream() is called
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 051eab0..f82983e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -28,7 +28,8 @@ check_PROGRAMS = \
test-add-remove-stream \
test-build-io-stream \
test-io-stream-thread \
- test-io-stream-closing \
+ test-io-stream-closing-write \
+ test-io-stream-closing-read \
test-io-stream-cancelling \
test-io-stream-pollable \
test-send-recv \
@@ -64,8 +65,11 @@ test_build_io_stream_LDADD = $(COMMON_LDADD)
test_io_stream_thread_SOURCES = test-io-stream-thread.c test-io-stream-common.c
test_io_stream_thread_LDADD = $(COMMON_LDADD)
-test_io_stream_closing_SOURCES = test-io-stream-closing.c test-io-stream-common.c
-test_io_stream_closing_LDADD = $(COMMON_LDADD)
+test_io_stream_closing_write_SOURCES = test-io-stream-closing-write.c test-io-stream-common.c
+test_io_stream_closing_write_LDADD = $(COMMON_LDADD)
+
+test_io_stream_closing_read_SOURCES = test-io-stream-closing-read.c test-io-stream-common.c
+test_io_stream_closing_read_LDADD = $(COMMON_LDADD)
test_io_stream_cancelling_SOURCES = test-io-stream-cancelling.c test-io-stream-common.c
test_io_stream_cancelling_LDADD = $(COMMON_LDADD)