summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authordafydd.harries <olivier.crete@collabora.co.uk>2006-09-26 21:50:00 +0000
committerdafydd.harries <olivier.crete@collabora.co.uk>2006-09-26 21:50:00 +0000
commita56cda3fd9f9aad105f297adf6a442d18be7a0f2 (patch)
tree952abec2e3763606899c2d5703d17fad8ca77fa8 /tests/Makefile.am
downloadlibnice-a56cda3fd9f9aad105f297adf6a442d18be7a0f2.tar.gz
import
darcs-hash:20060926215024-b59df-787a30444c3ae416c309322e1bdd26fd438fdc10.gz
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..bd6fd5b
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,10 @@
+
+AM_CFLAGS = -std=c99 -Wall -Werror
+
+test_SOURCES = test.c $(top_srcdir)/stun/stun.h $(top_srcdir)/stun/stun.c
+test_CFLAGS = -I$(top_srcdir)/stun $(AM_CFLAGS) @CHECK_CFLAGS@ @GLIB_CFLAGS@
+test_LDADD = @CHECK_LIBS@ @GLIB_LIBS@
+
+TESTS = test
+noinst_PROGRAMS = test
+