summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 0 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ffaa48..37c3a9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,14 +26,11 @@ DISTCHECK_CONFIGURE_FLAGS = --disable-assert -enable-gtk-doc --enable-introspect
EXTRA_DIST = \
COPYING.LGPL \
COPYING.MPL \
- README.win32 \
autogen.sh \
common.mk \
scripts/lcov.mk \
scripts/lcov.sh \
scripts/valgrind-test-driver \
- win32 \
- win32/vs9/libnice.def \
m4/introspection.m4 \
meson.build \
meson_options.txt
@@ -44,23 +41,6 @@ dist_check_SCRIPTS = \
scripts/check-symbols.sh \
scripts/make-symbol-list.sh
-# Generate the win32 DLL symbol export file.
-# The stun_*() symbols at the end have historically been exported on Windows
-# but not Linux, for no particular reason. They can’t be removed without
-# breaking ABI. FIXME: Remove them when we next break ABI.
-win32/vs9/libnice.def: nice/libnice.sym
- $(MKDIR_P) $(dir $@)
- $(AM_V_GEN)(echo "LIBRARY libnice"; \
- echo ""; \
- echo "EXPORTS"; \
- echo ""; \
- cat $<; \
- echo "stun_debug"; \
- echo "stun_debug_bytes"; \
- echo "stun_hash_creds") > $@
-
-CLEANFILES += win32/vs9/libnice.def
-
lcov:
find -name '*.gcda' -delete
$(MAKE) $(AM_MAKEFLAGS) check