summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 84c37be..c7b1fd9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,6 +8,9 @@
include $(top_srcdir)/common.mk
+TESTS_ENVIRONMENT=\
+ GST_PLUGIN_PATH=${GST_PLUGIN_PATH}:$(top_builddir)/gst
+
AM_CFLAGS = \
$(LIBNICE_CFLAGS) \
$(GLIB_CFLAGS) \
@@ -51,6 +54,10 @@ dist_check_SCRIPTS = \
check-test-fullmode-with-stun.sh \
test-pseudotcp-random.sh
+if HAVE_GST_CHECK
+check_PROGRAMS += test-gstreamer
+endif
+
TESTS = $(check_PROGRAMS) $(dist_check_SCRIPTS)
noinst_HEADERS = test-io-stream-common.h
@@ -109,6 +116,9 @@ test_tcp_LDADD = $(COMMON_LDADD)
test_icetcp_LDADD = $(COMMON_LDADD)
+test_gstreamer_CFLAGS = $(AM_CFLAGS) $(GST_CHECK_CFLAGS)
+test_gstreamer_LDADD = -lnice -L$(top_builddir)/nice/.libs $(GLIB_LIBS) $(GUPNP_LIBS) $(GST_CHECK_LIBS) $(GST_LIBS)
+
all-local:
chmod a+x $(srcdir)/check-test-fullmode-with-stun.sh
chmod a+x $(srcdir)/test-pseudotcp-random.sh