summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@redhat.com>2011-09-13 22:58:08 +0200
committerThomas Graf <tgraf@redhat.com>2011-09-13 22:58:08 +0200
commit4c210adcb572d8950fdc6b5135406e06e55f8b56 (patch)
treee4f354d4fdd7462dfa2b21c8833890bd5bb80db8 /Makefile.am
parenta73cb2f26932d90a2d47a28e9c524e7f33dcffbd (diff)
downloadlibnl-4c210adcb572d8950fdc6b5135406e06e55f8b56.tar.gz
Switch to libtool versioning system
It has been a request that multiple libnl versions should be installabe in parallel. In order to achieve this, the basename of the library was changed to libnl-3 which reflects the 3rd generation of libnl APIs. It also means that release based library versioning is left behind and libtool versioning is used instead. Projects using pkgconfig will automatically link against the new library basename and will not notice a difference. The SO versioning is based on the glib model: current := 100 * minor + micro - revision revision := revision age := age (number of backwards compatible versions)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 6706e4b..a936c49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,10 +10,10 @@ endif
SUBDIRS = include lib doc man python $(OPT_DIRS)
-pkgconfig_DATA = libnl-3.pc \
- libnl-route-3.pc \
- libnl-genl-3.pc \
- libnl-nf-3.pc
+pkgconfig_DATA = libnl-3.0.pc \
+ libnl-route-3.0.pc \
+ libnl-genl-3.0.pc \
+ libnl-nf-3.0.pc
pkgsysconfdir = ${sysconfdir}/libnl
pkgsysconf_DATA = etc/pktloc etc/classid