summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarl Hiramoto <karl@hiramoto.org>2010-06-16 16:33:51 +0200
committerThomas Graf <tgraf@suug.ch>2010-10-13 13:10:48 +0200
commit018c297274348acba1e123a3e84471c75a215efb (patch)
treeaea9dbbb741e430f2493a7435cd2b4161f7d6e8e /Makefile.am
parent6921b1c879e1423abe7e5ec9bd8bb4d89bb241e7 (diff)
downloadlibnl-018c297274348acba1e123a3e84471c75a215efb.tar.gz
libnl: optionally disable cli tools.
compile and link time can reduced, most non-developers don't need these cli tools. ./configure --disable-cli time make real 0m40.485s user 0m33.784s sys 0m2.793s ./configure time make real 0m53.097s user 0m42.077s sys 0m4.396s Signed-off-by: Karl Hiramoto <karl@hiramoto.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e1c47b9..8f9438c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,13 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = include lib src doc
+OPT_DIRS =
+
+if ENABLE_CLI
+OPT_DIRS += src
+endif
+
+SUBDIRS = include lib doc $(OPT_DIRS)
pkgconfig_DATA = libnl-2.0.pc