summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-11-11 01:33:51 +0100
committerThomas Graf <tgraf@redhat.com>2011-11-11 11:55:29 +0100
commit88940b71f81525b1080fcdd5a029537e9a85ca38 (patch)
tree62e2b7cc2e948600f34f8f03c88e6fbf2a060b4e /Makefile.am
parent32f30b739ab8cf542ac9b13f6c418ffa98c56c31 (diff)
downloadlibnl-88940b71f81525b1080fcdd5a029537e9a85ca38.tar.gz
build: simplify optional dirs/files in Makefile.am processing
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 7 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b8f020..e21060f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,21 +2,17 @@
ACLOCAL_AMFLAGS = -I m4
-OPT_DIRS =
-PKGCONFIGS =
-
-if ENABLE_CLI
-OPT_DIRS += src
-PKGCONFIGS += libnl-cli-3.0.pc
-endif
-
-SUBDIRS = include lib doc man python $(OPT_DIRS)
+SUBDIRS = include lib doc man python
pkgconfig_DATA = libnl-3.0.pc \
libnl-route-3.0.pc \
libnl-genl-3.0.pc \
- libnl-nf-3.0.pc \
- $(PKGCONFIGS)
+ libnl-nf-3.0.pc
+
+if ENABLE_CLI
+SUBDIRS += src
+pkgconfig_DATA += libnl-cli-3.0.pc
+endif
pkgsysconfdir = ${sysconfdir}/libnl