summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2007-09-15 01:28:01 +0200
committerThomas Graf <tgraf@suug.ch>2007-09-15 01:28:01 +0200
commit44d362409d5469aed47d19e7908d19bd194493a4 (patch)
tree5d1e739a4566f3af796273e5c3f78ca53d234df6 /configure.in
downloadlibnl-44d362409d5469aed47d19e7908d19bd194493a4.tar.gz
Initial import
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in80
1 files changed, 80 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..68aa586
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,80 @@
+#
+# configure.in
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation version 2.1
+# of the License.
+#
+# Copyright (c) 2003-2006 Thomas Graf <tgraf@suug.ch>
+#
+
+AC_INIT(libnl, 1.0-pre6, tgraf@suug.ch)
+AC_CONFIG_HEADER(lib/defs.h)
+
+save_CFLAGS="${CFLAGS}"
+save_LDFLAGS="${LDFLAGS}"
+save_CPPFLAGS="${CPPFLAGS}"
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+AC_C_CONST
+AC_C_INLINE
+
+#####################################################################
+##
+## libm check
+##
+#####################################################################
+M="No "
+AC_CHECK_LIB(m, pow,
+[
+ LIBM="-lm"
+ M="Yes"
+],[
+ echo
+ echo "*** Error: libm required ***"
+ echo
+ exit
+])
+
+#####################################################################
+##
+## verbose error strings
+##
+#####################################################################
+AC_ARG_ENABLE(verbose-errors,
+[ --enable-verbose-errors enable verbose errors (debugging)],[
+ if test x$enableval = xyes; then
+ AC_DEFINE_UNQUOTED(VERBOSE_ERRORS,"1",[verbose errors])
+ fi
+])
+
+#####################################################################
+##
+## compile decisions
+##
+#####################################################################
+COMPILE_LIBNL="Yes "
+LIBNL_LIB="$LIBM"
+
+AC_SUBST(LIBNL_LIB)
+
+AC_OUTPUT([Makefile.opts libnl-1.pc])
+
+#####################################################################
+##
+## status report
+##
+#####################################################################
+echo "
+----------------------------------------------------------------------
+SUMMARY:
+
+Included in Compilation:
+ libnl: $COMPILE_LIBNL $LIBNL_LIB
+
+Dependencies:
+bmon:
+ libm $M (required)"