summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Graf <tgraf@redhat.com>2012-10-19 16:16:06 +0200
committerThomas Graf <tgraf@redhat.com>2012-10-19 16:16:06 +0200
commitdb138439ac214d1259848ab11447d9b061ec3740 (patch)
tree39f8502783c98bb665af44d4d1c4c86feac89598 /configure.in
parent2d674fed6c0f1417ffa1dc73c43bb13993d15011 (diff)
downloadlibnl-db138439ac214d1259848ab11447d9b061ec3740.tar.gz
doc: Split doc/ into separate packages
Separates all the documentation generation trickery to its own configure.in and allows to easily generate a pre built doc dist file for distribution. Arguments to configure will be passed on to doc/configure Signed-off-by: Thomas Graf <tgraf@redhat.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in86
1 files changed, 2 insertions, 84 deletions
diff --git a/configure.in b/configure.in
index 28d1754..c0e6afa 100644
--- a/configure.in
+++ b/configure.in
@@ -73,88 +73,6 @@ AC_PROG_YACC
AC_C_CONST
AC_C_INLINE
-#
-# Generating the documentation
-#
-AC_ARG_ENABLE([doc],
- AS_HELP_STRING([--disable-doc], [Do not generate documentation]),
- [generate_doc="$enableval"], [generate_doc=auto])
-
-if test "x$generate_doc" != "xno"; then
- AC_PROG_SED
- AC_PROG_EGREP
-
- AX_PYTHON
-
- AC_CHECK_PROG(HAVE_DOXYGEN, [doxygen], yes, no)
- if test "x$HAVE_DOXYGEN" = "xno" -a "x$generate_doc" = "xyes"; then
- AC_MSG_ERROR([*** doxygen package required to generate documentation])
- fi
-
- AC_CHECK_PROG(HAVE_DOT, [dot], yes, no)
- if test "x$HAVE_DOT" = "xno"; then
- if test "x$generate_doc" = "xyes"; then
- AC_MSG_ERROR([*** graphviz package required to generate documentation])
- else
- AC_MSG_WARN([*** graphviz not found, disabling building of API reference])
- HAVE_DOXYGEN=no
- fi
- fi
-
- AC_CHECK_PROG(HAVE_ASCIIDOC, [asciidoc], yes, no)
- if test "x$HAVE_ASCIIDOC" = "xno"; then
- if test "x$generate_doc" = "xyes"; then
- AC_MSG_ERROR([*** asciidoc package required to generate documentation])
- else
- AC_MSG_WARN([*** asciidoc not found, disabling building of guides])
- fi
- fi
-
- AC_CHECK_PROG(HAVE_SOURCE_HIGHLIGHT, [source-highlight], yes, no)
- if test "x$HAVE_SOURCE_HIGHLIGHT" = "xno"; then
- if test "x$generate_doc" = "xyes"; then
- AC_MSG_ERROR([*** source-highlight required to generate documentation])
- else
- AC_MSG_WARN([*** source-highlight not found, disabling building of guides])
- HAVE_ASCIIDOC=no
- fi
- fi
-
- AC_CHECK_PROG(HAVE_MSCGEN, [mscgen], yes, no)
- if test "x$HAVE_MSCGEN" = "xno"; then
- AC_MSG_WARN([*** mscgen not found, get it at http://www.mcternan.me.uk/mscgen/])
- if test "x$generate_doc" = "xyes"; then
- AC_MSG_ERROR([*** mscgen package required to generate documentation])
- else
- AC_MSG_WARN([*** Disabling building of guides])
- HAVE_ASCIIDOC=no
- HAVE_DOXYGEN=no
- fi
- fi
-
- AC_CHECK_PROG(HAVE_PYGMENTIZE, [pygmentize], yes, no)
- if test "x$HAVE_PYGMENTIZE" = "xno"; then
- if test "x$generate_doc" = "xyes"; then
- AC_MSG_ERROR([*** pygmentize package required to generate documentation])
- else
- AC_MSG_WARN([*** Disabling building of guides])
- HAVE_ASCIIDOC=no
- fi
- fi
-
- link_doc=yes
- if test "x$HAVE_DOXYGEN" = "xno"; then
- AC_MSG_WARN([*** Disabling API linking due to missing doxygen package])
- link_doc=no
- fi
-fi
-
-AM_CONDITIONAL([LINK_DOC], [test "x$link_doc" = "xyes"])
-AM_CONDITIONAL([HAVE_DOXYGEN], [test "x$HAVE_DOXYGEN" = "xyes"])
-AM_CONDITIONAL([HAVE_ASCIIDOC], [test "x$HAVE_ASCIIDOC" = "xyes"])
-
-AM_CONDITIONAL([GENERATE_DOC], [test "x$generate_doc" != "xno"])
-
AC_ARG_WITH([pkgconfigdir], AS_HELP_STRING([--with-pkgconfigdir=PATH],
[Path to the pkgconfig directory [[LIBDIR/pkgconfig]]]),
[pkgconfigdir="$withval"], [pkgconfigdir='${libdir}/pkgconfig'])
@@ -168,6 +86,8 @@ AM_CONDITIONAL([ENABLE_CLI], [test "$enable_cli" = "yes"])
AC_CHECK_LIB([m], [pow], [], AC_MSG_ERROR([libm is required]))
AC_CHECK_LIB([pthread], [pthread_mutex_lock], [], AC_MSG_ERROR([libpthread is required]))
+AC_CONFIG_SUBDIRS([doc])
+
AC_CONFIG_FILES([
Makefile
libnl-3.0.pc
@@ -175,8 +95,6 @@ libnl-route-3.0.pc
libnl-genl-3.0.pc
libnl-nf-3.0.pc
libnl-cli-3.0.pc
-doc/Doxyfile
-doc/Makefile
lib/Makefile
include/Makefile
src/Makefile