summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2009-07-05 18:00:41 +0200
committerJan Engelhardt <jengelh@medozas.de>2009-07-05 18:00:41 +0200
commita73e5f92c378e96458ae88a3dc07514ee5856987 (patch)
treea044290f98ea5bd86f834a15b41db1585feb8146 /lib/Makefile.am
parentbf4fd3acee4e611afee20025f55454e37813f8ca (diff)
downloadlibnl-a73e5f92c378e96458ae88a3dc07514ee5856987.tar.gz
build: make use of library dependencies
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 118a077..4156f52 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -11,10 +11,12 @@ libnl_la_SOURCES = \
error.c handlers.c msg.c nl.c object.c socket.c utils.c
libnl_genl_la_LDFLAGS = -version-info 2:0:0
+libnl_genl_la_LIBADD = libnl.la
libnl_genl_la_SOURCES = \
genl/ctrl.c genl/family.c genl/genl.c genl/mngt.c
libnl_nf_la_LDFLAGS = -version-info 2:0:0
+libnl_nf_la_LIBADD = libnl-route.la
libnl_nf_la_SOURCES = \
netfilter/ct.c netfilter/ct_obj.c netfilter/log.c \
netfilter/log_msg.c netfilter/log_msg_obj.c netfilter/log_obj.c \
@@ -22,6 +24,7 @@ libnl_nf_la_SOURCES = \
netfilter/queue_msg.c netfilter/queue_msg_obj.c netfilter/queue_obj.c
libnl_route_la_LDFLAGS = -version-info 2:0:0
+libnl_route_la_LIBADD = libnl.la
libnl_route_la_SOURCES = \
route/addr.c route/class.c route/class_api.c route/class_obj.c \
route/classifier.c route/cls_api.c route/cls_obj.c route/link.c \