summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2010-10-29 00:20:42 +0200
committerThomas Graf <tgraf@suug.ch>2010-10-29 00:20:42 +0200
commitd7a561a1372f819efc8cede30dc550d8e3afcc28 (patch)
treeda9fefa62f5ffdca82fa374ebe0b207202719410 /lib/Makefile.am
parente1eacd6b16b014eb42bcf6683ebe2334c3a35c68 (diff)
downloadlibnl-d7a561a1372f819efc8cede30dc550d8e3afcc28.tar.gz
Tons of ematch work
- Fixes a bunch of bugs related to ematches - Adds support for the nbyte ematch - Adds a bison/flex parser for ematch expressions, expressions may look like this: ip.length > 256 && pattern(ip6.src = 3ffe::/16) documenation on syntax follows - adds ematch support to the basic classifier (--ematch EXPR)
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 52660ec..5a520cb 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -23,7 +23,9 @@ libnl_nf_la_SOURCES = \
CLEANFILES = \
route/pktloc_grammar.c route/pktloc_grammar.h \
- route/pktloc_syntax.c route/pktloc_syntax.h
+ route/pktloc_syntax.c route/pktloc_syntax.h \
+ route/cls/ematch_grammar.c route/cls/ematch_grammar.h \
+ route/cls/ematch_syntax.c route/cls/ematch_syntax.h
# Hack to avoid using ylwrap. It does not function correctly in combination
# with --header-file=
@@ -33,6 +35,12 @@ route/pktloc_grammar.c: route/pktloc_grammar.l
route/pktloc_syntax.c: route/pktloc_syntax.y
$(YACC) -d $(YFLAGS) -o $@ $^
+route/cls/ematch_grammar.c: route/cls/ematch_grammar.l
+ $(LEX) --header-file=route/cls/ematch_grammar.h $(LFLAGS) -o $@ $^
+
+route/cls/ematch_syntax.c: route/cls/ematch_syntax.y
+ $(YACC) -d $(YFLAGS) -o $@ $^
+
libnl_route_la_LIBADD = libnl.la
libnl_route_la_SOURCES = \
route/addr.c route/class.c route/class_api.c route/class_obj.c \
@@ -43,6 +51,11 @@ libnl_route_la_SOURCES = \
\
route/cls/fw.c route/cls/police.c route/cls/u32.c route/cls/basic.c \
\
+ route/cls/ematch_syntax.c route/cls/ematch_grammar.c \
+ route/cls/ematch.c \
+ route/cls/ematch/container.c route/cls/ematch/cmp.c \
+ route/cls/ematch/nbyte.c \
+ \
route/link/api.c route/link/vlan.c \
\
route/sch/blackhole.c route/sch/cbq.c route/sch/dsmark.c \