summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@redhat.com>2012-04-21 10:34:43 +0200
committerThomas Graf <tgraf@redhat.com>2012-04-21 10:34:43 +0200
commit9af54690041aaa0a4934c336709bdf42a57afe28 (patch)
treecad2d3ffc003bebac1317c0a00ea9ddd9f25e444 /tests/Makefile.am
parent653ea3457a2d6d74aa0ba877d7b0e1cd6309fb40 (diff)
downloadlibnl-9af54690041aaa0a4934c336709bdf42a57afe28.tar.gz
tests: Convert tests/Makefile to use automake
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..4193818
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,31 @@
+# -*- Makefile -*-
+
+AM_CPPFLAGS = -Wall -I${top_srcdir}/include -I${top_builddir}/include -D_GNU_SOURCE -DSYSCONFDIR=\"$(sysconfdir)/libnl\"
+
+LDADD = \
+ ${top_builddir}/src/lib/libnl-cli-3.la \
+ ${top_builddir}/lib/libnl-3.la \
+ ${top_builddir}/lib/libnl-nf-3.la \
+ ${top_builddir}/lib/libnl-genl-3.la \
+ ${top_builddir}/lib/libnl-route-3.la
+
+check_PROGRAMS = \
+ test-cache-mngr \
+ test-create-bond \
+ test-create-vlan \
+ test-delete-link \
+ test-genl \
+ test-nf-cache-mngr \
+ test-socket-creation
+
+# Eventually add these to TESTS once converted to be real
+# test programs
+# TESTS = $(check_PROGRAMS)
+
+test_cache_mngr_SOURCES = test-cache-mngr.c
+test_create_bond_SOURCES = test-create-bond.c
+test_create_vlan_SOURCES = test-create-vlan.c
+test_delete_link_SOURCES = test-delete-link.c
+test_genl_SOURCES = test-genl.c
+test_nf_cache_mngr_SOURCES = test-nf-cache-mngr.c
+test_socket_creation_SOURCES = test-socket-creation.c