summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7bf3423..8ea76cb 100644
--- a/configure.in
+++ b/configure.in
@@ -132,6 +132,16 @@ if test "x$generate_doc" != "xno"; then
fi
fi
+ AC_CHECK_PROG(HAVE_PYGMENTIZE, [pygmentize], yes, no)
+ if test "x$HAVE_PYGMENTIZE" = "xno"; then
+ if test "x$generate_doc" = "xyes"; then
+ AC_MSG_ERROR([*** pygmentize package required to generate documentation])
+ else
+ AC_MSG_WARN([*** Disabling building of guides])
+ HAVE_ASCIIDOC=no
+ fi
+ fi
+
link_doc=yes
if test "x$HAVE_DOXYGEN" = "xno"; then
AC_MSG_WARN([*** Disabling API linking due to missing doxygen package])