summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-09-09 00:36:19 +0000
committerDavid Schleef <ds@schleef.org>2004-09-09 00:36:19 +0000
commit16cae73a6e7c9e1d218a6ac247f5226823de02b4 (patch)
tree81ce41fb755b805933f7f1450079d82a00db9b82 /configure.ac
parent44780dcad77eba8256cc3e1bd63978c97dd9ffae (diff)
downloadliboil-16cae73a6e7c9e1d218a6ac247f5226823de02b4.tar.gz
* configure.ac: Use -Wa,-mregnames if possible
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2eb5a6c..10d6520 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,11 @@ if test "x$LIBOIL_CVS" = "xyes"
then
AS_COMPILER_FLAG(-Werror, LIBOIL_CFLAGS="$LIBOIL_CFLAGS -Werror")
fi
+if test x$HAVE_CPU_POWERPC = xyes ; then
+ AS_COMPILER_FLAG(["-Wa,-mregnames"],
+ [LIBOIL_CFLAGS="$LIBOIL_CFLAGS -Wa,-mregnames"],
+ true)
+fi
LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_GNU_SOURCE -D_POSIX_C_SOURCE=200112L -I\$(top_srcdir)"
AC_SUBST(LIBOIL_CFLAGS)