summaryrefslogtreecommitdiff
path: root/orc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'orc/Makefile.am')
-rw-r--r--orc/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/orc/Makefile.am b/orc/Makefile.am
index bb0d56e..b46eaac 100644
--- a/orc/Makefile.am
+++ b/orc/Makefile.am
@@ -5,6 +5,11 @@ lib_LTLIBRARIES = liborc-@LIBOIL_MAJORMINOR@.la
liborc_@LIBOIL_MAJORMINOR@_la_LIBS = $(LIBOIL_LIBS) $(GLIB_LIBS)
liborc_@LIBOIL_MAJORMINOR@_la_CFLAGS = $(LIBOIL_CFLAGS) $(GLIB_CFLAGS)
+liborc_@LIBOIL_MAJORMINOR@_la_LDFLAGS = \
+ -no-undefined \
+ -version-info $(LIBOIL_LIBVERSION) \
+ -export-symbols-regex '^orc_'
+
liborc_@LIBOIL_MAJORMINOR@_la_SOURCES = \
orc.c \
@@ -17,12 +22,18 @@ liborc_@LIBOIL_MAJORMINOR@_la_SOURCES = \
orcprogram-powerpc.c \
orcprogram.h \
orcopcodes.c \
- orcprogram-linux.c \
orcrules-mmx.c \
orcrules-x86.c \
orcrules-sse.c \
x86.c
+if HAVE_OS_LINUX
+liborc_@LIBOIL_MAJORMINOR@_la_SOURCES += orcprogram-linux.c
+else
+liborc_@LIBOIL_MAJORMINOR@_la_SOURCES += orcprogram-unknown-os.c
+endif
+
+
pkginclude_HEADERS = \
orc.h \
orcprogram.h \