summaryrefslogtreecommitdiff
path: root/orc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'orc/Makefile.am')
-rw-r--r--orc/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/orc/Makefile.am b/orc/Makefile.am
deleted file mode 100644
index b46eaac..0000000
--- a/orc/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
-
-pkgincludedir = $(includedir)/orc-@LIBOIL_MAJORMINOR@/orc
-
-lib_LTLIBRARIES = liborc-@LIBOIL_MAJORMINOR@.la
-
-liborc_@LIBOIL_MAJORMINOR@_la_LIBS = $(LIBOIL_LIBS) $(GLIB_LIBS)
-liborc_@LIBOIL_MAJORMINOR@_la_CFLAGS = $(LIBOIL_CFLAGS) $(GLIB_CFLAGS)
-liborc_@LIBOIL_MAJORMINOR@_la_LDFLAGS = \
- -no-undefined \
- -version-info $(LIBOIL_LIBVERSION) \
- -export-symbols-regex '^orc_'
-
-
-liborc_@LIBOIL_MAJORMINOR@_la_SOURCES = \
- orc.c \
- orcexecutor.c \
- orcrule.c \
- orctype.c \
- orcprogram.c \
- orcprogram-c.c \
- orcprogram-x86.c \
- orcprogram-powerpc.c \
- orcprogram.h \
- orcopcodes.c \
- orcrules-mmx.c \
- orcrules-x86.c \
- orcrules-sse.c \
- x86.c
-
-if HAVE_OS_LINUX
-liborc_@LIBOIL_MAJORMINOR@_la_SOURCES += orcprogram-linux.c
-else
-liborc_@LIBOIL_MAJORMINOR@_la_SOURCES += orcprogram-unknown-os.c
-endif
-
-
-pkginclude_HEADERS = \
- orc.h \
- orcprogram.h \
- x86.h
-