summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-05 06:52:13 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-05 06:52:13 +0000
commitbd7a46eae67dbbe1ebf2bda3b8073b31e732042d (patch)
tree2b46686d96490d0a8753c146183dee4c126d064b /CMakeLists.txt
parent513d1993329889a56a0611adbdf7bd887535af74 (diff)
downloadlibproxy-git-bd7a46eae67dbbe1ebf2bda3b8073b31e732042d.tar.gz
massive rework; split off libmodman; make unit tests for libmodman; remove config_wpad; remove config_file (both intenal and module); remove config ordering support; merge lukas' kde plugin rework
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1776c9b..7abc067 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,9 @@ project(libproxy)
# Set the version
set(CMAKE_PROJECT_VERSION 0.4.0)
+# Enable testing
+enable_testing()
+
# Setup our relative paths
if(${WIN32})
set(rlibdir .)
@@ -39,6 +42,7 @@ else()
endif()
### Subdirectories
+add_subdirectory(libmodman)
add_subdirectory(libproxy)
add_subdirectory(bindings)
add_subdirectory(utils)