summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2020-11-27 20:58:33 -0800
committerChristian Hergert <chergert@redhat.com>2020-11-27 20:58:33 -0800
commit474b4c21d1f24261627a93a636e9a36190bdca88 (patch)
tree39270d3e06919713edefde10a29608967179119e /Makefile.am
parent1adc7ca8f98ff1a7b498a034708a011a79adf58a (diff)
downloadlibrsvg-wip/chergert/fix-macos-link.tar.gz
build: use -framework Foundation on macOSwip/chergert/fix-macos-link
This fixes an issue where link symbols are not available for basic Obj-C message passing and other release/retain operations. Fixes #545
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9013a95e..d9204fd5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -204,6 +204,10 @@ librsvg_@RSVG_API_MAJOR_VERSION@_la_LDFLAGS = \
-export-symbols-regex "^rsvg_.*" \
$(AM_LDFLAGS)
+if OS_DARWIN
+librsvg_@RSVG_API_MAJOR_VERSION@_la_LDFLAGS += -framework Foundation
+endif
+
librsvg_@RSVG_API_MAJOR_VERSION@_la_LIBADD = \
librsvg_c_api.la \
$(LIBRSVG_LIBS) \