summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKleis Auke Wolthuizen <github@kleisauke.nl>2019-10-16 09:54:03 +0200
committerKleis Auke Wolthuizen <github@kleisauke.nl>2019-10-16 09:54:03 +0200
commit8cea2b36244d4508d07d84440087c9c392b834ef (patch)
tree9a06c40eafb3bd2cf2c7f1b0bd66afd2fb3498ca /Makefile.am
parentad86ab8580c8779fc3eb2bee2422bb116919844e (diff)
downloadlibrsvg-8cea2b36244d4508d07d84440087c9c392b834ef.tar.gz
Add a dummy file, to make sure the library is non-empty
Should fix the macOS build.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a04828c9..b28ddd73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ noinst_LTLIBRARIES = librsvg_c_api.la
# This is empty, because automake wants to have a C sources list for
# the LTLIBRARIES. See LIBRSVG_INTERNALS_SRC below for the real list
# of Rust sources.
-librsvg_c_api_la_SOURCES =
+librsvg_c_api_la_SOURCES = librsvg/dummy.c
bin_PROGRAMS = rsvg-convert
@@ -182,7 +182,7 @@ dist-hook:
mkdir .cargo && \
cp cargo-vendor-config .cargo/config)
-librsvg_c_api.la: $(LIBRSVG_INTERNALS_SRC) $(LIBRSVG_C_API_SRC)
+librsvg_c_api.la: $(librsvg_c_api_la_OBJECTS) $(LIBRSVG_INTERNALS_SRC) $(LIBRSVG_C_API_SRC)
+cd $(top_srcdir)/librsvg && \
PKG_CONFIG_ALLOW_CROSS=1 \
PKG_CONFIG='$(PKG_CONFIG)' \
@@ -191,7 +191,7 @@ librsvg_c_api.la: $(LIBRSVG_INTERNALS_SRC) $(LIBRSVG_C_API_SRC)
&& if [[ $$($(NM) -g $(RUST_LIB) | grep "T __*clzsi2" -c) -gt 1 ]] ; then \
$(AR) d $(RUST_LIB) clzsi2.o; \
fi \
- && cd $(LIBRSVG_BUILD_DIR) && $(LINK) && mv $(RUST_LIB) .libs/librsvg_c_api.a
+ && cd $(LIBRSVG_BUILD_DIR) && $(LINK) $< && mv $(RUST_LIB) .libs/librsvg_c_api.a
librsvg_@RSVG_API_MAJOR_VERSION@_la_CPPFLAGS = \
-I$(top_srcdir) \