summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@gnome.org>2020-01-09 12:43:33 -0600
committerFederico Mena Quintero <federico@gnome.org>2020-01-09 12:43:33 -0600
commita5fc7af7a8b4128c26511171063cb99a215750d2 (patch)
tree352034460941631d51bc060fbd863826933a67aa /Makefile.am
parenteaa99fd0012c78232a8ce1becd9e8a0274405353 (diff)
downloadlibrsvg-a5fc7af7a8b4128c26511171063cb99a215750d2.tar.gz
Write test output from the Rust tests to the same output/ dir from the C tests
This keeps "make distcheck" happy.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 36cf4abe..d2ab8a3e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -157,13 +157,13 @@ RUST_LIB=$(CARGO_TARGET_DIR)/$(RUST_TARGET_SUBDIR)/librsvg_c_api.a
endif
check-local:
- cd $(srcdir) && \
- CARGO_TARGET_DIR=$(CARGO_TARGET_DIR) \
- OUT_DIR=$(LIBRSVG_BUILD_DIR) \
+ cd $(srcdir) && \
+ CARGO_TARGET_DIR=$(CARGO_TARGET_DIR) \
+ OUT_DIR=$(LIBRSVG_BUILD_DIR)/tests/output \
$(CARGO) --locked test $(CARGO_VERBOSE) $(CARGO_TARGET_ARGS) $(CARGO_RELEASE_ARGS)
clean-local:
- cd $(top_srcdir) && \
+ cd $(top_srcdir) && \
CARGO_TARGET_DIR=$(CARGO_TARGET_DIR) \
$(CARGO) clean