summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Schubert <feartohell@seznam.cz>2015-05-09 05:21:43 +0200
committerAdam Schubert <feartohell@seznam.cz>2015-05-09 05:21:43 +0200
commit47d065eb6f90a4cf54f3f49a97c4dd551ce3e064 (patch)
tree4c3db88e11432bc04cd13b4993eccb7c83a6933c /CMakeLists.txt
parent779ccb98dcfb4263b4b57192750c9609a88fc67a (diff)
downloadlibrsync-47d065eb6f90a4cf54f3f49a97c4dd551ce3e064.tar.gz
Run prototab generator when running cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dbc8ada..6ab697c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,7 @@ if (NOT CMAKE_SYSTEM_NAME)
message(FATAL_ERROR "No target OS set")
endif()
+execute_process(COMMAND perl "${CMAKE_SOURCE_DIR}/mkprototab.pl" "prototab.c" "prototab.h")
include ( CheckIncludeFiles )
check_include_files ( alloca.h HAVE_ALLOCA_H )