summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Schubert <feartohell@seznam.cz>2015-05-09 13:10:35 +0200
committerAdam Schubert <feartohell@seznam.cz>2015-05-09 13:10:35 +0200
commitf63c481aa7bb4e1de4984dfca0d12f6ae72f0b66 (patch)
tree678bc4a068173e4fcbf52e11fefb0464ca0ca9ea /CMakeLists.txt
parent7f475363a39e2699b6702952a58b9441aed400e6 (diff)
downloadlibrsync-f63c481aa7bb4e1de4984dfca0d12f6ae72f0b66.tar.gz
Link popt to rdiff not to librsync
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ab697c..86db1c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -161,7 +161,6 @@ set(rsync_LIB_SRCS
add_library(rsync SHARED ${rsync_LIB_SRCS})
target_link_libraries(rsync
-${POPT_LIBRARIES}
${BZIP2_LIBRARIES}
${ZLIB_LIBRARIES}
)
@@ -182,7 +181,7 @@ set(rdiff_SRCS
add_executable(rdiff ${rdiff_SRCS})
-target_link_libraries(rdiff rsync)
+target_link_libraries(rdiff rsync ${POPT_LIBRARIES})
#install(TARGETS rdiff ${INSTALL_TARGETS_DEFAULT_ARGS})