summaryrefslogtreecommitdiff
path: root/libsoup/meson.build
diff options
context:
space:
mode:
authorTomas Popela <tpopela@redhat.com>2019-04-23 09:07:54 +0200
committerTomas Popela <tpopela@redhat.com>2019-04-23 09:54:23 +0200
commitc4a9252b612861bf70a1b8cd0b2a84eb9f5f386e (patch)
tree2ba6bd91a5c8fcc0d4c561fb19b01cfaa70b88bd /libsoup/meson.build
parent6b5945ea1b60876a9cd6fd5fcff9cffb7aa62fb9 (diff)
downloadlibsoup-c4a9252b612861bf70a1b8cd0b2a84eb9f5f386e.tar.gz
Fix the build of tests on MinGW
Currently the tests are failing to build with "undefined reference to `_imp__htonl@4'". The fix is to add the platform_deps to tests dependencies. Do that by adding it to the libsoup_dep thus all the targets are fixed. https://gitlab.gnome.org/GNOME/libsoup/merge_requests/60
Diffstat (limited to 'libsoup/meson.build')
-rw-r--r--libsoup/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/libsoup/meson.build b/libsoup/meson.build
index bfef032d..861cba2f 100644
--- a/libsoup/meson.build
+++ b/libsoup/meson.build
@@ -246,7 +246,7 @@ pkg.generate(libsoup,
libsoup_dep = declare_dependency(link_with : libsoup,
include_directories : configinc,
sources : soup_enum_h,
- dependencies : glib_dep)
+ dependencies : [ platform_deps, glib_dep ])
if enable_gnome
soup_gnome_api_name = 'soup-gnome-' + apiversion