summaryrefslogtreecommitdiff
path: root/libsoup/meson.build
diff options
context:
space:
mode:
authorTomas Popela <tpopela@redhat.com>2018-12-17 12:57:24 +0100
committerTomas Popela <tpopela@redhat.com>2018-12-17 16:18:49 +0100
commitdb8b4a90b21452fdf6519dad2211ce81c954b7c2 (patch)
treea8d6f903c9d800f8f9d57fe69104794128079644 /libsoup/meson.build
parentb0b59d39c403d874f3c1ad564256b32ae4e87b6f (diff)
downloadlibsoup-db8b4a90b21452fdf6519dad2211ce81c954b7c2.tar.gz
meson: Be able to build the static library
Don't use the meson's shared_library() target, but the library() one, so we are able to change the library type through the default_library option. Also disable introspection if the static library is requested as the gnome.generate_gir() needs an executable or a shared library.
Diffstat (limited to 'libsoup/meson.build')
-rw-r--r--libsoup/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/libsoup/meson.build b/libsoup/meson.build
index 2b149a0e..eaa74d12 100644
--- a/libsoup/meson.build
+++ b/libsoup/meson.build
@@ -223,7 +223,7 @@ deps = [
platform_deps
]
-libsoup = shared_library('soup-@0@'.format(apiversion),
+libsoup = library('soup-@0@'.format(apiversion),
soup_sources,
soup_headers,
soup_enums,
@@ -262,7 +262,7 @@ if enable_gnome
soup_gnome_installed_headers,
subdir : includedir)
- libsoup_gnome = shared_library(soup_gnome_api_name,
+ libsoup_gnome = library(soup_gnome_api_name,
soup_gnome_sources + soup_gnome_headers,
version : libversion,
soversion : soversion,