summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 1cae853d..c847a254 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -7,10 +7,10 @@ abs_installed_tests_execdir = join_paths(prefix, installed_tests_execdir)
if cc.get_id() == 'msvc'
test_utils = static_library(test_utils_name, test_utils_name + '.c',
- dependencies : libsoup_static_dep)
+ dependencies : [ libsoup_static_dep, unix_socket_dep ])
else
test_utils = library(test_utils_name, test_utils_name + '.c',
- dependencies : libsoup_static_dep,
+ dependencies : [ libsoup_static_dep, unix_socket_dep ],
install : installed_tests_enabled,
install_dir : installed_tests_execdir,
)
@@ -81,6 +81,12 @@ if brotlidec_dep.found()
endif
endif
+if unix_socket_dep.found()
+ tests += [
+ ['unix-socket', true, [ unix_socket_dep ]],
+ ]
+endif
+
if have_apache
tests += [
['auth', false, []],