summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2007-12-10 17:07:21 +0100
committerSimon Josefsson <simon@josefsson.org>2007-12-10 17:07:21 +0100
commitf8844d13028ef1322f17c5e8058fb3d983cc546f (patch)
tree35313f8f115459bbfa5a1f8b917fb94785ccea26 /Makefile.am
parent49f0fab4785aca16df035bff819772fe96589097 (diff)
downloadlibtasn1-f8844d13028ef1322f17c5e8058fb3d983cc546f.tar.gz
Fix release target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index dbb87a7..8c47e55 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,16 +37,18 @@ htmldir = ../www-gnutls
tag = $(PACKAGE)_`echo $(VERSION) | sed 's/\./_/g'`
release:
- ! git-tag -l $(tag) > /dev/null
+ ! git-tag -l $(tag) | grep $(PACKAGE) > /dev/null
rm -f ChangeLog
$(MAKE) ChangeLog distcheck
+ cd doc && ../build-aux/gendocs.sh -o ../$(htmldir)/manual/libtasn1/ $(PACKAGE) "Libtasn1"
+ cp -v doc/reference/html/*.{html,png,devhelp,css} $(htmldir)/manual/libtasn1/reference/
+ cp -v $(distdir).tar.gz{,.sig} $(htmldir)/releases/libtasn1/
git commit -m Generated. ChangeLog
git-tag -u b565716f! -m $(VERSION) $(tag)
+ git-push --tags
+ git-push
gpg -b $(distdir).tar.gz
gpg --verify $(distdir).tar.gz.sig
- cd doc && ../build-aux/gendocs.sh -o ../$(htmldir)/manual/libtasn1/ $(PACKAGE) "Libtasn1"
- cp -v doc/reference/html/*.{html,png,devhelp,css} $(htmldir)/manual/libtasn1/reference/
- cp -v $(distdir).tar.gz{,.sig} $(htmldir)/releases/libtasn1/
scp $(distdir).tar.gz{,.sig} igloo.linux.gr:~ftp/pub/gnutls/libtasn1/
ssh igloo.linux.gr 'cd ~ftp/pub/gnutls/libtasn1/ && sha1sum *.tar.gz > CHECKSUMS'
cd $(htmldir) && \