summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2008-08-29 12:48:32 +0200
committerSimon Josefsson <simon@josefsson.org>2008-08-29 12:48:32 +0200
commitf191c4c88422d008ad624206fa065719070ff8b2 (patch)
treecf90f9a2654c2cc88dbad43ded8e6e3ef6c41772 /Makefile.am
parentfdca5ec21b2c98b67d9c371caa395c119b5fa885 (diff)
downloadlibtasn1-f191c4c88422d008ad624206fa065719070ff8b2.tar.gz
Fix release target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 1 insertions, 25 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ba11bd..dd99065 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,28 +30,4 @@ SUBDIRS = gl lib src examples tests doc
ACLOCAL_AMFLAGS = -I m4 -I gl/m4
-ChangeLog:
- git log --pretty --numstat --summary | git2cl > ChangeLog
-
-htmldir = ../www-gnutls
-tag = $(PACKAGE)_`echo $(VERSION) | sed 's/\./_/g'`
-
-release:
- ! git-tag -l $(tag) | grep $(PACKAGE) > /dev/null
- rm -f ChangeLog
- $(MAKE) ChangeLog distcheck
- gpg -b $(distdir).tar.gz
- gpg --verify $(distdir).tar.gz.sig
- cd doc && ../build-aux/gendocs.sh -o ../$(htmldir)/manual/libtasn1/ $(PACKAGE) "Libtasn1"
- cp -v doc/reference/html/*.html doc/reference/html/*.png doc/reference/html/*.devhelp doc/reference/html/*.css $(htmldir)/manual/libtasn1/reference/
- cp -v $(distdir).tar.gz $(distdir).tar.gz.sig $(htmldir)/releases/libtasn1/
- git commit -m Generated. ChangeLog
- git-tag -u b565716f! -m $(VERSION) $(tag)
- git-push --tags
- git-push
- scp $(distdir).tar.gz $(distdir).tar.gz.sig igloo.linux.gr:~ftp/pub/gnutls/libtasn1/
- ssh igloo.linux.gr 'cd ~ftp/pub/gnutls/libtasn1/ && sha1sum *.tar.gz > CHECKSUMS'
- cd $(htmldir) && \
- cvs add -kb releases/libtasn1/$(distdir).tar.gz \
- releases/libtasn1/$(distdir).tar.gz.sig && \
- cvs commit -m "Update." manual/libtasn1/ releases/libtasn1/
+EXTRA_DIST = cfg.mk maint.mk .clcopying