summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-02-29 10:26:39 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-02-29 10:29:56 +0100
commit18d6b624473b3864908bb010e37189513fd095b1 (patch)
tree36a58ed2b13ea4522254ad0aeb0cdfb9e6ee3efd /configure.ac
parent0570b22afd6b771d55bcac2503759b082ddc86a7 (diff)
downloadlibtasn1-18d6b624473b3864908bb010e37189513fd095b1.tar.gz
configure: added --disable-doc
This allows to conditionally build the documentation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 455ef69..056aa84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,11 @@ gl_EARLY
lgl_EARLY
AC_PROG_YACC
+AC_ARG_ENABLE(doc,
+ AS_HELP_STRING([--disable-doc], [don't generate any documentation]),
+ enable_doc=$enableval, enable_doc=yes)
+AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" != "no")
+
dnl Checks for programs.
AM_MISSING_PROG(HELP2MAN, help2man, $missing_dir)
AC_LIBTOOL_WIN32_DLL