summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 379525e..0d8fcb1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,7 +25,7 @@ LDADD = ../lib/libtasn1.la ../gl/libgnu.la
EXTRA_DIST = Test_parser.asn Test_tree.asn Test_tree_asn1_tab.c \
Test_encoding.asn pkix.asn TestIndef.p12 choice.asn coding-decoding2.asn \
TestIndef2.p12 TestIndef3.der TestCertOctetOverflow.der \
- libtasn1.supp ocsp-basic-response.der \
+ libtasn1.supp ocsp-basic-response.der spc_pe_image_data.der \
invalid-x509/id-000000.der invalid-x509/id-000001.der \
invalid-x509/id-000002.der invalid-x509/id-000003.der \
invalid-x509/id-000004.der invalid-x509/id-000005.der \
@@ -54,13 +54,15 @@ MOSTLYCLEANFILES = Test_parser_ERROR.asn
check_PROGRAMS = Test_parser Test_tree Test_encoding Test_indefinite \
Test_errors Test_simple Test_overflow Test_strings Test_choice \
Test_encdec copynode coding-decoding2 strict-der Test_choice_ocsp \
- ocsp-basic-response octet-string coding-long-oid object-id-decoding
+ ocsp-basic-response octet-string coding-long-oid object-id-decoding \
+ spc_pe_image_data
TESTS = Test_parser Test_tree Test_encoding Test_indefinite \
Test_errors Test_simple Test_overflow crlf threadsafety \
Test_strings Test_choice Test_encdec copynode coding-decoding2 \
strict-der Test_choice_ocsp decoding decoding-invalid-x509 \
- ocsp-basic-response octet-string coding-long-oid object-id-decoding
+ ocsp-basic-response octet-string coding-long-oid object-id-decoding \
+ spc_pe_image_data
TESTS_ENVIRONMENT = \
ASN1PARSER=$(srcdir)/Test_parser.asn \
@@ -76,6 +78,8 @@ TESTS_ENVIRONMENT = \
ASN1CHOICE_OCSP=$(srcdir)/pkix.asn \
ASN1CHOICE_OCSP_DATA=$(srcdir)/ocsp.der \
ASN1_RESPONSE_OCSP_DATA=$(srcdir)/ocsp-basic-response.der \
+ ASN1_MSCAT=$(srcdir)/mscat.asn \
+ ASN1_SPC_PE_IMAGE_DATA=$(srcdir)/spc_pe_image_data.der \
THREADSAFETY_FILES=`find $(top_srcdir)/lib -name \*.c` \
EXEEXT=$(EXEEXT) \
LSAN_OPTIONS=suppressions=libtasn1.supp \