summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPete Batard <pbatard@gmail.com>2011-03-08 17:16:23 +0000
committerPeter Stuge <peter@stuge.se>2011-06-13 22:06:30 +0200
commitae675c1f49dc00b695fce7296903f60998cc28ed (patch)
treec25a24a16afc6afc98f6fb93ed16396c901d8320 /configure.ac
parent356e312511e4892977636da52ec497ad2c716032 (diff)
downloadlibusb-ae675c1f49dc00b695fce7296903f60998cc28ed.tar.gz
Windows: Remove SetupAPI, AdvAPI32 and OLE32 link-time dependencies
* this ensures that libusb dependent applications only need to explicitly link against libusb on Windows The run-time dependency on Cfgmgr32.dll, OLE32.dll and SetupAPI.dll remains.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ed84e42..b805b23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,7 +77,7 @@ esac
if test "$backend" = windows; then
AC_DEFINE(OS_WINDOWS, 1, [Windows backend])
AC_SUBST(OS_WINDOWS)
- PC_LIBS_PRIVATE="-lsetupapi -lole32 -ladvapi32"
+ PC_LIBS_PRIVATE=""
LTLDFLAGS="${LTLDFLAGS} -avoid-version -Wl,--add-stdcall-alias"
AC_CHECK_TOOL(RC, windres, no)
AC_DEFINE([POLL_NFDS_TYPE],[unsigned int],[type of second poll() argument])