summaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
authorPete Batard <pbatard@gmail.com>2010-03-10 13:19:38 +0000
committerPete Batard <pbatard@gmail.com>2010-03-10 13:19:38 +0000
commitea78e1ce73c018eff041555ab41448fc889ce278 (patch)
tree44e7f8b5448b5310b83c2e6abc3cc5fd2cc85b64 /libusb/Makefile.am
parentfae9c17bd2405813d44186c94367d6e66d3994e6 (diff)
downloadlibusb-ea78e1ce73c018eff041555ab41448fc889ce278.tar.gz
merge up to r202c191
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
index c252b3d..48b28fb 100644
--- a/libusb/Makefile.am
+++ b/libusb/Makefile.am
@@ -8,7 +8,7 @@ endif
LINUX_USBFS_SRC = $(THREADS_SRC) os/poll_posix.h os/linux_usbfs.h os/linux_usbfs.c
DARWIN_USB_SRC = $(THREADS_SRC) os/poll_posix.h os/darwin_usb.h os/darwin_usb.c
-WINDOWS_USB_SRC = $(THREADS_SRC) os/poll_windows.h os/poll_windows.c os/windows_usb.h os/windows_usb.c
+WINDOWS_USB_SRC = $(THREADS_SRC) os/poll_windows.h os/poll_windows.c os/windows_usb.h os/windows_usb.c libusb-1.0.rc
EXTRA_DIST = $(LINUX_USBFS_SRC) $(DARWIN_USB_SRC) $(WINDOWS_USB_SRC)
@@ -23,6 +23,8 @@ endif
if OS_WINDOWS
OS_SRC = $(WINDOWS_USB_SRC)
+.rc.lo:
+ $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(RC) $(RCFLAGS) -i $< -o $@
endif
libusb_1_0_la_CFLAGS = $(VISIBILITY_CFLAGS) $(AM_CFLAGS)