summaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
authorPeter Stuge <peter@stuge.se>2012-01-12 10:34:55 +0100
committerPeter Stuge <peter@stuge.se>2012-01-12 10:34:55 +0100
commitcdc5df8f1b206a7c19bc221e8a9a97d5d98deb85 (patch)
tree7eb31e1f4c5264e59e317af2864c6f30979c6fe9 /libusb/Makefile.am
parenta8e2e7cab278fbfcba91909eaf762cf66da9eda5 (diff)
downloadlibusb-cdc5df8f1b206a7c19bc221e8a9a97d5d98deb85.tar.gz
libusb/Makefile.am: Avoid recursive variables in .rc silent-rule
Not every make supports recursive variable expansion so some automake versions complain about non-POSIX variable names ever since commit 70bec4a9f8ec28d36c731011fa24d37c74ad3523 which added support for silent-rules in our rule to compile the Windows .rc file. This commit removes the recursive variables and instead uses the simple and generic GEN message and associated variable.
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
index 5152c38..c009376 100644
--- a/libusb/Makefile.am
+++ b/libusb/Makefile.am
@@ -19,12 +19,8 @@ endif
if OS_WINDOWS
OS_SRC = $(WINDOWS_USB_SRC)
-pkg_v_rc = $(pkg_v_rc_$(V))
-pkg_v_rc_ = $(pkg_v_rc_$(AM_DEFAULT_VERBOSITY))
-pkg_v_rc_0 = @echo " RC $@";
-
.rc.lo:
- $(pkg_v_rc)$(LIBTOOL) $(AM_V_lt) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --tag=RC --mode=compile $(RC) $(RCFLAGS) -i $< -o $@
+ $(AM_V_GEN)$(LIBTOOL) $(AM_V_lt) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --tag=RC --mode=compile $(RC) $(RCFLAGS) -i $< -o $@
libusb-1.0.rc: version.h
endif