summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-08-22 11:18:04 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-08-22 11:18:04 +0200
commite303e5e5c6b99f25ce20da324d5c417427c87aaa (patch)
treeb228bcacfcd25d019081f37c275815efe785a8b6 /Makefile.am
parentf48a802937cbd74e40dc503f712439433b77da71 (diff)
downloadlibva-intel-driver-e303e5e5c6b99f25ce20da324d5c417427c87aaa.tar.gz
Moved files around.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am99
1 files changed, 0 insertions, 99 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 405489b4..00000000
--- a/Makefile.am
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright (c) 2007 Intel Corporation. All Rights Reserved.
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the
-# "Software"), to deal in the Software without restriction, including
-# without limitation the rights to use, copy, modify, merge, publish,
-# distribute, sub license, and/or sell copies of the Software, and to
-# permit persons to whom the Software is furnished to do so, subject to
-# the following conditions:
-#
-# The above copyright notice and this permission notice (including the
-# next paragraph) shall be included in all copies or substantial portions
-# of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
-# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
-# IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
-# ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
-# TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
-# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-SUBDIRS = shaders
-
-INCLUDES = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/va \
- -I$(top_srcdir)/va/x11 \
- -DPTHREADS \
- $(DRM_CFLAGS) \
- $(NULL)
-
-driver_cflags = \
- -Wall \
- -fvisibility=hidden \
- $(NULL)
-
-driver_ldflags = \
- -module -avoid-version \
- -no-undefined \
- -Wl,--no-undefined \
- $(DRM_LIBS) -ldrm_intel \
- $(NULL)
-
-source_c = \
- gen6_mfc.c \
- gen6_mfd.c \
- gen6_vme.c \
- gen7_mfd.c \
- i965_avc_bsd.c \
- i965_avc_hw_scoreboard.c\
- i965_avc_ildb.c \
- i965_drv_video.c \
- i965_encoder.c \
- i965_media.c \
- i965_media_h264.c \
- i965_media_mpeg2.c \
- i965_post_processing.c \
- i965_render.c \
- intel_batchbuffer.c \
- intel_batchbuffer_dump.c\
- intel_driver.c \
- intel_memman.c \
- object_heap.c \
- $(NULL)
-
-source_h = \
- gen6_mfc.h \
- gen6_mfd.h \
- gen6_vme.h \
- gen7_mfd.h \
- i965_avc_bsd.h \
- i965_avc_hw_scoreboard.h\
- i965_avc_ildb.h \
- i965_defines.h \
- i965_drv_video.h \
- i965_encoder.h \
- i965_media.h \
- i965_media_h264.h \
- i965_media_mpeg2.h \
- i965_mutext.h \
- i965_post_processing.h \
- i965_render.h \
- i965_structs.h \
- intel_batchbuffer.h \
- intel_batchbuffer_dump.h\
- intel_compiler.h \
- intel_driver.h \
- intel_memman.h \
- object_heap.h \
- $(NULL)
-
-i965_drv_video_la_LTLIBRARIES = i965_drv_video.la
-i965_drv_video_ladir = $(LIBVA_DRIVERS_PATH)
-i965_drv_video_la_CFLAGS = $(driver_cflags)
-i965_drv_video_la_LDFLAGS = $(driver_ldflags)
-i965_drv_video_la_LIBADD = $(top_builddir)/va/libva-x11.la -lpthread
-i965_drv_video_la_SOURCES = $(source_c)
-noinst_HEADERS = $(source_h)