summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhao halley <halley.zhao@intel.com>2012-05-24 17:13:31 +0800
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-09-26 16:05:25 +0200
commit4019121f7fc4bce540372c4938cecc0ad3d74168 (patch)
treed0a4915bc035ff7127d33ed1515f97b284e11dc8 /configure.ac
parenta559a09ede754079f92b7a8eaec6cf1d8f9e7186 (diff)
downloadlibva-4019121f7fc4bce540372c4938cecc0ad3d74168.tar.gz
wayland: ship with wayland-drm protocol.
Signed-off-by: Zhao Halley <halley.zhao@intel.com> Signed-off-by: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c2c192..6a6a8d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,6 +287,10 @@ if test "$enable_wayland" = "yes"; then
fi
AM_CONDITIONAL(USE_WAYLAND, test "$USE_WAYLAND" = "yes")
+m4_ifdef([WAYLAND_SCANNER_RULES],
+ [WAYLAND_SCANNER_RULES(['$(top_srcdir)/va/wayland/protocol'])],
+ [wayland_scanner_rules=""; AC_SUBST(wayland_scanner_rules)])
+
# We only need the headers, we don't link against the DRM libraries
LIBVA_CFLAGS="$DRM_CFLAGS"
AC_SUBST(LIBVA_CFLAGS)
@@ -339,6 +343,7 @@ AC_OUTPUT([
va/glx/Makefile
va/va_version.h
va/wayland/Makefile
+ va/wayland/protocol/Makefile
va/x11/Makefile
])